ดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งาน
php 5.4 ออกความสามารถใหม่ มาทำให้เราสร้างตัวแปล array ได้ง่ายขึ้น โดยเขียนสั้นลง แต่ Host ทั่วไปยังไม่รองรับนะครับ อย่าเพิ่งเอามาใช้จริงจัง
ถ้าจะให้ก็ต้องเขียน เช็คเวอร์ชั่นของ php เครื่องที่เราใช้กันก่อน
รูปแบบ
<?php
// เดิม ใช้ได้ php น้อยกว่า 5.4
$array 
= array(
    
"foo" => "bar",
    
"bar" => "foo"
);

//  PHP 5.4 เป็นต้นไป
$array = [
    
"foo" => "bar",
    
"bar" => "foo"
];
?>
โดยที่ key ของ array ใช้ได้ทั้ง integer และ string และนอกจากนี้ Float, Bool , Null