เกิด error การติดตั้ง eCommerce ด้วย Joomla virtuemart

พูดคุย phpBB3, SMF ปัญหา การติดตั้ง ปัญหา การลง Mod การแก้ไข หน้าตาบอร์ด การใช้งาน Joomla 1.5, 1.6, 1.7, 2.5 ,3.x และเร็วๆนี้ Joomla จะออกเวอร์ชั่น 4.0 การใช้งาน wordpress และ CMS อื่นๆ
การตั้งคำถาม ควรระบุรุ่นที่ใช้ ในการตั้งคำตามด้วย นะ เช่น SMF 1.1.4 หรือ SMF2.0 Joomla 1.0 joomla 3.8 และ รายละเอียดของ server OS , php เวอร์ชั่นไหน ฐานข้อมูลอะไร

Moderator: mindphp

Forum rules
คำถามหมวดนี้ ควรระบุ รายละเอียดของ Server OS, เวอร์ชั่น ของ PHP, CMS ที่ท่านใช้
รวมถึง Hosting หรือ Control Panel Hosting
ozzy_dnet
PHP Newbie
PHP Newbie
Posts: 3
Joined: 23/06/2012 1:26 am

Re: เกิด error การติดตั้ง eCommerce ด้วย Joomla virtuemart

Post by ozzy_dnet »

สำหรับตัวนี้
LaiThai_eCommerce_Edition_VM_1.1.8_Joomla_1.5.23

ถ้าใช้กับ WAMP เวอร์ชั่นใหม่ๆ เช่น 2.2 จะเกิด MySql ERROR..!!
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM AUTO_INCREMENT=5 COMMENT='Holds all the user groups'' ..............

แก้ได้โดย แก้ไฟล์
..\installation\sql\mysql\virtuemart.installation.joomla.sql
หรือ
C:\wamp\www\เวปของท่าน\installation\sql\mysql\virtuemart.installation.joomla.sql

Find and Replace หาคำว่า

TYPE=MyISAM เปลี่ยนเป็น ENGINE=MyISAM

และ
timestamp(14) เปลี่ยนเป็น timestamp

ได้แน่นอนครับ :mrgreen:
อ้อ Find หา MyISAM อีกรอบ จะเห็นมี TYPE= เหลือค้างอยู่อีกเพราะเว้นวรรคไม่เท่ากัน
แก้เป็น ENGINE= แล้วSave
Attachments
virtuemart.installation.joomla.rar
โหลดไฟล์นี้ไปทับเลยก็ได้
(29.27 KiB) Downloaded 106 times

ozzy_dnet
PHP Newbie
PHP Newbie
Posts: 3
Joined: 23/06/2012 1:26 am

Re: เกิด error การติดตั้ง eCommerce ด้วย Joomla virtuemart

Post by ozzy_dnet »

ส่วนปัญหาข้อ1. จริงแล้วเวลาในการ sesion หมดอายุครับ จะเห็นว่าพอท่านกลับไป Login ใหม่ก็ผ่านแล้วครับ

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests