ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

พูดคุย phpBB3, SMF ปัญหา การติดตั้ง ปัญหา การลง Mod การแก้ไข หน้าตาบอร์ด การใช้งาน Joomla 1.5, 1.6, 1.7, 2.5 ,3.x และเร็วๆนี้ Joomla จะออกเวอร์ชั่น 4.0 การใช้งาน wordpress และ CMS อื่นๆ
การตั้งคำถาม ควรระบุรุ่นที่ใช้ ในการตั้งคำตามด้วย นะ เช่น SMF 1.1.4 หรือ SMF2.0 Joomla 1.0 joomla 3.8 และ รายละเอียดของ server OS , php เวอร์ชั่นไหน ฐานข้อมูลอะไร

Moderator: mindphp

Forum rules
คำถามหมวดนี้ ควรระบุ รายละเอียดของ Server OS, เวอร์ชั่น ของ PHP, CMS ที่ท่านใช้
รวมถึง Hosting หรือ Control Panel Hosting
kitsana_na
PHP Jr. Member
PHP Jr. Member
Posts: 21
Joined: 18/06/2012 11:49 am

ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by kitsana_na » 18/06/2012 2:46 pm

ใช้joomla 2.5 ครับ แต่มันอัพขึ้น Host ไม่ได้ แก้ไฟล์ config แล้วก็ยังไมได้ มันขึ้นคำนี้ครับ
Fatal error: Call to undefined function spl_autoload_register() in D:\nationalpark\nopd\libraries\loader.php on line 237 ต้องทำไงครับ
พอเข้าเข้า phpmyadmin ใน Host มันขึ้นคำว่า The mbstring PHP extension was not found and you seem to be using multibyte charset. Without mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results. กับ Your PHP MySQL library version 4.1.7 differs from your MySQL server version 5.5.19. This may cause unpredictable behavior. ทำไงครับ ช่วยหน่อยครับ ลองทำเองมาเป็นอาทิตย์แล้วยังทำไม่ได้เลยครับ

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 23819
Joined: 22/09/2008 6:18 pm
Contact:

Re: ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by mindphp » 18/06/2012 2:56 pm

Host เช่า หรือ Host Free ครับ
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042

kitsana_na
PHP Jr. Member
PHP Jr. Member
Posts: 21
Joined: 18/06/2012 11:49 am

Re: ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by kitsana_na » 18/06/2012 3:58 pm

เป็น Host ของกรมที่ทำงานอยู่หนะครับ เค้าแบ่งบ๊อกให้สร้างเวบของส่วน ผมจะทำเวบส่วนหนะครับ แต่ติดตรงอัพขึ้น Host ไม่ได้ซักที ลงใหม่ก็ไม่ได้ มันบอกว่าYour host needs to use PHP 5.2.4 or higher to run Joomla ทั้งที่ php ที่ใช้ก็เป็นเวอชั่น 5.5 อะครับ ช่วยหน่อยนะครับ

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 23819
Joined: 22/09/2008 6:18 pm
Contact:

Re: ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by mindphp » 18/06/2012 4:17 pm

Joomla 2.5
ต้องใช้ php 5.2 x หรือสูงกว่า
ตามข้อความที่ยกมา
5.5 นั่นมันเวอร์ชั่นของ Mysql ครับ
และ Mysql ที่ลงไว้ library ที่ทำให้ php ติดต่อ Mysql ก็ไม่ตรงเวอร์ชั่นกัน
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042

kitsana_na
PHP Jr. Member
PHP Jr. Member
Posts: 21
Joined: 18/06/2012 11:49 am

Re: ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by kitsana_na » 18/06/2012 4:34 pm

ถามแบบคนไม่รู้จริง ๆ นะครับ mysql กับ myphp มันคนละอันกันเหรอครับ ทีนี้ผมต้องทำไงครับ คือต้องให้คนดูแลระบบเค้าลง php 5.2x ให้รึเปล่าครับ แสดงว่าของผมที่ทำใน localhost php ผมเวอร์ชั่นสูงกว่าที่ Host เค้าทำให้ ผมถามยังงี้ถูกต้องมั๊ยครับ รบกวนหน่อยนะนะครับ ไม่รู้จริง ๆ คนดูแลระบบเค้าก็ทำไม่เป็นอะครับ ในหนังสือก็ไม่ได้บอก

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 23819
Joined: 22/09/2008 6:18 pm
Contact:

Re: ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by mindphp » 18/06/2012 4:40 pm

เอาโค้ดนี้ save เป็นชื่อ phpinfo.php

Code: Select all

<?php 
phpinfo();
?>
แล้วไปวาง ใน web server ดู แล้วจับภาพหน้าจอมาดูหน่อยครับ
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042

kitsana_na
PHP Jr. Member
PHP Jr. Member
Posts: 21
Joined: 18/06/2012 11:49 am

Re: ช่วยหน่อยครับ อัพขึ้น Host ที่ทำงานไม่ได้

Post by kitsana_na » 18/06/2012 4:46 pm

สงสัยจะไม่ได้แล้วหละครับ เพราะว่าทางผู้ดูแลระบบเค้าใช้ php เวอร์ชั่น 5.05 แล้วเค้าบอกว่าอัพขึ้นไม่ได้เพราะจะไปกระทบกับคนที่เค้าสร้างเวบของที่อื่นหนะครับ สรุปผมต้องกลับไปทำ joomla 1.5 ใช่เปล่าครับถึงจะรองรับอะครับ เดี๋ยวพรุ่งนี้มาถามต่อนะครับ ต้องรีบกลับ ขอบคุณมากจริง ๆ ครับ

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM”

Who is online

Users browsing this forum: No registered users and 10 guests