Page 1 of 2

ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 1:51 pm
by kitsana_na
ตอนลง จูมล่า 1.5 ใน Host ขั้นตอนสุดท้ายอะครับ มันขึ้นยังงี้ ต้องทำไงครับ
Fatal error: Call to undefined function memory_get_usage() in D:\nationalpark\nopd\mywebsite\libraries\joomla\crypt\crypt.php on line 85 ช่วยหน่อยนะครับใช้ 2.5 ก็ลงHostที่ทำงานไม่ได้ พอเปลี่ยนมาเป็น 1.5 กลับลงแล้วเออเร่อซะงั้น ขอบคุณมากครับ

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 1:52 pm
by imsn
ที่ Host ไม่มี ฟังก์ชั่น memory_get_usage() ให้ใช้ แบร่ๆ Host ที่ไหนเนี่ย

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 1:57 pm
by kitsana_na
แล้วต้องทำไงครับ ช่วยหน่อยนะครับ จนปัญญาจริง ๆ เลย มือใหม่ช่วยทีครับ เป็น Host ของกรมอุทยานครับ

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 1:59 pm
by imsn
ติดต่อ Host โลดครับ

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 3:15 pm
by kitsana_na
แล้วผมต้องบอกเค้าว่าไงครับ คนดูแลระบบยังไม่ค่อยเป็นมวยเท่าไรเลย ช่วยแก้ใขอะไรให้ผมก็ไม่ได้ ไม่ค่อยอยากจะไปถามอะไรเลย สุดท้ายก็ต้องมานั่ง งง เองอยู่ประจำ

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 4:27 pm
by mindphp
Function memory_get_usage() ไว้สำหรับอ่านค่าการใช้ แรมของ Server ที่ php เอามาใช้
เริ่มมีใช้ ตั้งแต่ php เวอร์ชั่น 4.3.2
เข้าใจว่า Host คุณ kitsana_na น่าจะเป็นเวอร์ชั่นที่เก่ากว่านั้น หรือ ถ้ามากว่านั้นคนติดตั้งเค้าไม่ได้ใส่ function นี้เข้ามา หรือ ไปยกเลิก มันครับ

ทางแก้แบบเลี่ยงๆ ทำได้ ด้วยสร้าง function memory_get_usage หลอกๆ ขึ้นมา แต่ไม่แนะนำให้แก้ที่สาเหตุดีกว่าครับ Server ตอนนี้ควรลง php 5.2 หรือ 5.3 ไปเลย ไม่งั้นเราจะล้าสมัยมากๆ โปรแกรมใหม่ๆ หรือความสามารถใหม่ๆ ของ Joomla เองก็จะใช้ไม่ได้ ตอนนี้ Joomla 1.5 คนพัฒนาเค้าหยุดแล้ว ไปทำ ตัว 2.5 และเวอร์ชั่นอื่นที่สูงขึ้นไปกว่านี้

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 5:19 pm
by kitsana_na
เค้าบอกว่าเปลี่ยนเป็น php 5.2 หรือ 5.3 ไม่ได้ครับเพราะจะกระทบกับคนที่ทำเวบก่อนหน้านี้ที่ใช้ Host เดียวกัน ส่วนตัวผมว่าไม่น่าเกี่ยว แต่ผมทำไรไม่ได้ครับเค้าบอกมายังงั้น เวบที่ทำเสร็จก็เป็น จูมล่า 2.5 แต่ต้องกลับมาเปลี่ยนเป็น 1.5 ก็เพราะมันลงไม่ได้นี่แหละครับ แล้วกลับมาเจอปัญหานี่อีก ที่ว่าทำหลอก ๆ นี่ทำไงเหรอครับ ช่วยสอนหน่อยนะครับ

Re: ช่วยหน่อยครับ เปลี่ยนมาลง 1.5 แล้วมันเออเร่อ

Posted: 25/06/2012 5:23 pm
by mindphp
kitsana_na wrote:เค้าบอกว่าเปลี่ยนเป็น php 5.2 หรือ 5.3 ไม่ได้ครับเพราะจะกระทบกับคนที่ทำเวบก่อนหน้านี้ที่ใช้ Host เดียวกัน ส่วนตัวผมว่าไม่น่าเกี่ยว แต่ผมทำไรไม่ได้ครับเค้าบอกมายังงั้น เวบที่ทำเสร็จก็เป็น จูมล่า 2.5 แต่ต้องกลับมาเปลี่ยนเป็น 1.5 ก็เพราะมันลงไม่ได้นี่แหละครับ แล้วกลับมาเจอปัญหานี่อีก ที่ว่าทำหลอก ๆ นี่ทำไงเหรอครับ ช่วยสอนหน่อยนะครับ
ถ้า Host ไม่ support ตั้งแต่ต้น ผ่านปัญหานี้ได้ ก็เจอปัญหาอื่นๆ ตามมาอีกเยอะ