ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

พูดคุย phpBB3, SMF ปัญหา การติดตั้ง ปัญหา การลง Mod การแก้ไข หน้าตาบอร์ด การใช้งาน Joomla 1.5, 1.6, 1.7, 2.5 ,3.x และเร็วๆนี้ Joomla จะออกเวอร์ชั่น 4.0 การใช้งาน wordpress และ CMS อื่นๆ
การตั้งคำถาม ควรระบุรุ่นที่ใช้ ในการตั้งคำตามด้วย นะ เช่น SMF 1.1.4 หรือ SMF2.0 Joomla 1.0 joomla 3.8 และ รายละเอียดของ server OS , php เวอร์ชั่นไหน ฐานข้อมูลอะไร

Moderator: mindphp

Forum rules
คำถามหมวดนี้ ควรระบุ รายละเอียดของ Server OS, เวอร์ชั่น ของ PHP, CMS ที่ท่านใช้
รวมถึง Hosting หรือ Control Panel Hosting
jubjib
PHP Newbie
PHP Newbie
Posts: 4
Joined: 08/02/2010 11:02 pm

ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by jubjib »

ติดตั้ง ตามขั้นตอนที่เว็ปบอกแล้วค่ะ แต่ว่าถึงตอนฐานข้อมูล โปรแกรมฟ้องมีข้อผิดพลาดค่ะ
แล้วข้อความข้างล่างนี้มันขึ้นบนหัวค่ะ แก้ไขยังไงค่ะ

Deprecated: Assigning the return value of new by reference is deprecated in D:\xampp\htdocs\joomla15\libraries\pattemplate\patTemplate.php on line 1424

Deprecated: Assigning the return value of new by reference is deprecated in D:\xampp\htdocs\joomla15\libraries\pattemplate\patErrorManager.php on line 202
User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 25643
Joined: 22/09/2008 6:18 pm
Contact:

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ

Post by mindphp »

ใช้ php เวอร์ชั่นอะไร
ขอรายละเอียด Server ที่ติดตั้งด้วยครับ
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042
batigole
PHP Newbie
PHP Newbie
Posts: 3
Joined: 07/02/2010 12:16 pm

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by batigole »

ขอสอบถามหน่อนะครับ
ไม่ทราบว่าตรวจสอบรุ่นของ
php ตรงไหนเหรอครับ
เพราะผมใช้ XAMPP 1.7.3 ลง
เลยคิดว่ามันลงให้ด้วย :-D
jubjib
PHP Newbie
PHP Newbie
Posts: 4
Joined: 08/02/2010 11:02 pm

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by jubjib »

ดาวน์โหลดจากตัวนี้ค่ะ
XAMPP Windows 1.7.3, 2009/12/23
[Basic package]
ZIP 100 MB ZIP archive

including:
•Apache 2.2.14 (IPv6 enabled) + OpenSSL 0.9.8l
•MySQL 5.1.41 + PBXT engine
•PHP 5.3.1
•phpMyAdmin 3.2.4
•Perl 5.10.1
•FileZilla FTP Server 0.9.33
•Mercury Mail Transport System 4.72
User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 25643
Joined: 22/09/2008 6:18 pm
Contact:

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by mindphp »

แนะนำให้ ติดตั้ง XAMPP ที่มี php เวอร์ชั่นต่ำกว่า 5.3 นะครับ
เป็น ข้อผิดพลาดของ Joomla ที่ทำงานกับ php 5.3
ถ้าใช้ xampp แนะนำเวอร์ชั่น 1.7.1 เพราะมันใช้ php เวอร์ชั่น 5.2.9
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042
jubjib
PHP Newbie
PHP Newbie
Posts: 4
Joined: 08/02/2010 11:02 pm

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by jubjib »

พี่ค่ะ jubjib เปลี่ยนมาใช้ php v.5.2.9 โหลดจากที่นี่ค่ะ http://www.oldapps.com/xampp.php?old_xampp=44
เป็น XAMPP 1.7.1 แต่ก็ยังไม่ได้ค่ะ
Versions
•Apache 2.2.11
•MySQL 5.1.33 (Community Server)
•PHP 5.2.9 + PEAR (Support for PHP 4 has been discontinued)
•XAMPP Control Version 2.5 from www.nat32.com
•XAMPP CLI Bundle 1.3 from Carsten Wiedmann
•XAMPP Security 1.0
•SQLite 2.8.15
•OpenSSL 0.9.8i
•phpMyAdmin 3.1.3.1
•ADOdb 5.06a
•Mercury Mail Transport System v4.62
•FileZilla FTP Server 0.9.31
•Webalizer 2.01-10
•Zend Optimizer 3.3.0
•eAccelerator 0.9.5.3 für PHP 5.2.9 (but not activated in the php.ini)

*ติดตั้ง XAMPP ใน D:\ ใช่หรือเปล่าค่ะ
** joomla ที่จะใช้ติดตั้งต้องเป็น versions อะไรค่ะถึงจะใช้ร่วมกับ XAMPP 1.7.1 (jubjib ใช้ Joomla_1.5.1-Stable-Full_Package) ตัวนี้ค่ะ
*** มันก็ยังไม่ได้ค่ะ ประมาณว่ามันมีข้อผิดพลาดว่า port 80 or 443(SSL) already in use! Installing Apahe 2.2 service faild
port 3306 already in use! Installing Mysql service faild
port 21 already in use! Installing FileZilla FTPP service faild
หมายความว่าไงค่ะ ต้องแก้จุดไหนค่ะ
****รบกวนพี่อีกครั้งนะค่ะ ว่าควรจะลงอะไร v.ไหน กับโปรแกรมไหน แล้วแก้ปัญหาตรงนี้ยังไง ขอบคุณค่ะ
User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 25643
Joined: 22/09/2008 6:18 pm
Contact:

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by mindphp »

ต้องเอา เวอร์ชั่นเก่าออกก่อนครับ
ตามที่แจ้ง error แจ้ง เพราะ service ของเก่าค้างทำใช้ start ใหม่ไม่ได้

ตอนนี้แนะนำ XAMPP 1.7.1 , Joomla 1.5.15
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042
jubjib
PHP Newbie
PHP Newbie
Posts: 4
Joined: 08/02/2010 11:02 pm

Re: ติดตั้งแล้วเกิดข้อผิดพลาดค่ะ Deprecated: Assigning the return value of new by re

Post by jubjib »

ขอบคุณค่ะ เดี๋ยวลองทำก่อนนะค่ะ
Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM”

Who is online

Users browsing this forum: No registered users and 4 guests