แก้ปัญหา ติดตั้ง PHP 7.4 ไม่ได้ บน Server เจอ Error error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were no

สอบถามเรื่องทั่วไป กับ การใช้คอมพิวเตอร์โดยทั่วไป แนะนำข่าวสารไวรัสคอม เทคนิคเล็กน้อยๆ กับ การใช้ คอมพิวเตอร์ ให้มีประสิทธิภาพมากที่สุด ฝากคำถามไว้ได้นะค่ะ

Moderators: mindphp, ผู้ดูแลกระดาน

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 26657
Joined: 22/09/2008 6:18 pm
Contact:

แก้ปัญหา ติดตั้ง PHP 7.4 ไม่ได้ บน Server เจอ Error error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were no

Post by mindphp »

แก้ปัญหา ติดตั้ง PHP 7.4 ไม่ได้ บน Server เจอ Error error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were no
บน Directadmin
checking for icu-uc >= 50.1 icu-io icu-i18n... no
configure: error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were not met:

Requested 'icu-uc >= 50.1' but version of icu-uc is 4.8.1.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ICU_CFLAGS
and ICU_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** There was an error while trying to configure php. Check the configure file
ปัญหามาจากเวอร์ชั่น ของ icu-uc
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042
User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 26657
Joined: 22/09/2008 6:18 pm
Contact:

Re: แก้ปัยหา ติดตั้ง PHP 7.4 ไม่ได้ บน Server เจอ Error

Post by mindphp »

แก้ปัญหาโดย update icu ก่อนติดตั้ง PHP 7.4
เช็คว่า มีไฟล์ /usr/local/icu/include/unicode/uvernum.h อยู่ใน OS เราหรือเปล่า ถ้ามี
ลุยต่อ update icu ด้วย Comand

Code: Select all

cd /usr/local/directadmin/custombuild
./build update
./build icu
เพิ่มเติม ถ้าใครใช้ CentOS 6 ลิงค์ไฟล์ lib icu ตามคำสั่งด้านล่างนี้ ก่อน

Code: Select all

ln -sf /usr/local/icu/lib/libicudata.so /usr/lib64/libicudata.so
ln -sf /usr/local/icu/lib/libicui18n.so /usr/lib64/libicui18n.so
ln -sf /usr/local/icu/lib/libicuio.so /usr/lib64/libicuio.so
ln -sf /usr/local/icu/lib/libicuuc.so /usr/lib64/libicuuc.so
ศึกษาเพิ่มเติม ติดตั้ง Extension เสริมใน PHP
viewtopic.php?f=27&t=38380&p=201908#p201908
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042
User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 26657
Joined: 22/09/2008 6:18 pm
Contact:

Re: แก้ปัญหา ติดตั้ง PHP 7.4 ไม่ได้ บน Server เจอ Error error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) wer

Post by mindphp »

เพิ่มเติม
PHP 7.4 ไม่สามารถติดตั้ง บน Ubuntu 14 และ CentOS 6
(แต่ไม่ใช่ไม่สามารถ ซะทีเดียวพอมีวิธีปรับ lib ต่างๆ ให้ติดตั้งได้)
ไม่เหมาะสำหรับมือใหม่
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042
Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ถาม - ตอบ คอมพิวเตอร์”

Who is online

Users browsing this forum: No registered users and 6 guests