มีปัญหาเรื่องการลง appserv คับ

สำหรับผู้ที่ เริ่มต้น Programming - PHP มีอะไร แนะนำ หรือข้อสงสัยต้องบอร์ด นี้ คนที่มีความรู้ แบ่งปันคนอื่นบ้างนะ ปัญหาการเขียนโปรแกรม แบบ OOP Session Cookies php network

Moderators: mindphp, ผู้ดูแลกระดาน

avatarhero

มีปัญหาเรื่องการลง appserv คับ

Post by avatarhero » 24/05/2010 4:03 pm

ติดตั้ง appserv เสดแล้วแต่เข้า http://localhost, 127.0.0.1, และ http://localhost/phpMyAdmin ไม่ได้คับ
ลองลบแล้วลงใหม่ (ลองอยู่ 2 version 2.5.10 กับ 2.6.0)
ลองเปลี่ยน port ก้อแล้ว
เชคดูใน service Apache กับ Mysql ก้อรันอยู่ทั้ง 2 ตัว
ปิด firewall ก้อแล้ว
เวลาเข้า มานขึ้น status ว่า waiting for localhost แล้วมันก็วิ่งไม่หยุด
ไม่ขึ้นหน้า error ใดๆเลย
รบกวนใครพอมีความรู้ช่วยหน่อยนะคับ

User avatar
imsn
PHP Super Member
PHP Super Member
Posts: 375
Joined: 07/05/2010 12:58 pm
Contact:

Re: มีปัญหาเรื่องการลง appserv คับ

Post by imsn » 24/05/2010 4:57 pm

ลอง ดู Error log ซิครับ
ช่วยตอบเพราะอยากโปรโหมทเว็บ คิคิคลิกเลย
หาเพื่อนฝรั่งคุย M ...

avatarhero

Re: มีปัญหาเรื่องการลง appserv คับ

Post by avatarhero » 24/05/2010 5:11 pm

Starting the Apache2.2 service
The Apache2.2 service is running.
rmine the server's fully qualified domain name, using 10.0.0.109 for ServerName
[Thu Jan 31 20:30:15 2008] [notice] Apache/2.2.8 (Win32) configured -- resuming normal operations
[Thu Jan 31 20:30:15 2008] [notice] Server built: Jan 18 2008 00:37:19
[Thu Jan 31 20:30:15 2008] [notice] Parent: Created child process 756
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 10.0.0.109 for ServerName
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 10.0.0.109 for ServerName
[Thu Jan 31 20:30:15 2008] [notice] Child 756: Child process is running
[Thu Jan 31 20:30:15 2008] [notice] Child 756: Acquired the start mutex.
[Thu Jan 31 20:30:15 2008] [notice] Child 756: Starting 64 worker threads.
[Thu Jan 31 20:30:15 2008] [notice] Child 756: Starting thread to listen on port 80.
[Thu Jan 31 20:30:22 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Jan 31 20:30:22 2008] [notice] Child 756: Exit event signaled. Child process is ending.
[Thu Jan 31 20:30:23 2008] [notice] Child 756: Released the start mutex
[Thu Jan 31 20:30:24 2008] [notice] Child 756: All worker threads have exited.
[Thu Jan 31 20:30:24 2008] [notice] Child 756: Child process is exiting
[Thu Jan 31 20:30:24 2008] [notice] Parent: Child process exited successfully.
Starting the Apache2.2 service
The Apache2.2 service is running.
to load dynamic library 'C:/AppServ\\php5\\ext\\php_exif.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Mon May 24 15:53:30 2010] [notice] Apache/2.2.8 (Win32) PHP/5.2.6 configured -- resuming normal operations
[Mon May 24 15:53:30 2010] [notice] Server built: Jan 18 2008 00:37:19
[Mon May 24 15:53:30 2010] [notice] Parent: Created child process 3108
PHP Warning: PHP Startup: Unable to load dynamic library 'C:/AppServ\\php5\\ext\\php_exif.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Mon May 24 15:53:30 2010] [notice] Child 3108: Child process is running
[Mon May 24 15:53:30 2010] [notice] Child 3108: Acquired the start mutex.
[Mon May 24 15:53:30 2010] [notice] Child 3108: Starting 64 worker threads.
[Mon May 24 15:53:30 2010] [notice] Child 3108: Starting thread to listen on port 80.
[Mon May 24 16:58:19 2010] [warn] pid file C:/AppServ/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
PHP Warning: PHP Startup: Unable to load dynamic library 'C:/AppServ\\php5\\ext\\php_exif.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Mon May 24 16:58:28 2010] [notice] Apache/2.2.8 (Win32) PHP/5.2.6 configured -- resuming normal operations
[Mon May 24 16:58:28 2010] [notice] Server built: Jan 18 2008 00:37:19
[Mon May 24 16:58:28 2010] [notice] Parent: Created child process 3292
PHP Warning: PHP Startup: Unable to load dynamic library 'C:/AppServ\\php5\\ext\\php_exif.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Mon May 24 16:58:28 2010] [notice] Child 3292: Child process is running
[Mon May 24 16:58:28 2010] [notice] Child 3292: Acquired the start mutex.
[Mon May 24 16:58:28 2010] [notice] Child 3292: Starting 64 worker threads.
[Mon May 24 16:58:28 2010] [notice] Child 3292: Starting thread to listen on port 80.

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 23792
Joined: 22/09/2008 6:18 pm
Contact:

Re: มีปัญหาเรื่องการลง appserv คับ

Post by mindphp » 24/05/2010 10:59 pm

ลอง comment php_exif.dll ที่ php.ini ออกก่อนครับ
แต่จริงๆ อยากแนะนำให้ใช้ xampp ดีกว่า ครับ
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042

avatarhero

Re: มีปัญหาเรื่องการลง appserv คับ

Post by avatarhero » 25/05/2010 8:16 am

[Tue May 25 07:55:31 2010] [notice] Apache/2.2.4 (Win32) PHP/5.2.3 configured -- resuming normal operations
[Tue May 25 07:55:31 2010] [notice] Server built: Jan 9 2007 23:17:20
[Tue May 25 07:55:31 2010] [notice] Parent: Created child process 3536
[Tue May 25 07:55:32 2010] [notice] Child 3536: Child process is running
[Tue May 25 07:55:32 2010] [notice] Child 3536: Acquired the start mutex.
[Tue May 25 07:55:32 2010] [notice] Child 3536: Starting 64 worker threads.
[Tue May 25 07:55:32 2010] [notice] Child 3536: Starting thread to listen on port 80.

ยังคงไม่ได้อะคับ

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 23792
Joined: 22/09/2008 6:18 pm
Contact:

Re: มีปัญหาเรื่องการลง appserv คับ

Post by mindphp » 25/05/2010 11:19 am

ไม่ได้ มันขึ้น Error ที่หน้า localhost ว่าอะไรครับ
ที่ port 80 มีโปรแกรมอื่นอยู่หรือเปล่า เช่น skype
แต่ดูตาม log แล้วไม่น่าจะมีปัญหา
ถ้ายังมีปัญหา อีกลูกดู service ของ Apache ว่าที่ path ไปที่ไหน
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042

avatarhero

Re: มีปัญหาเรื่องการลง appserv คับ

Post by avatarhero » 26/05/2010 9:40 am

ที่หน้า localhost ไม่ขึ้นอะไรเลยคับ
ที่ status มันขึ้นว่า waiting for localhost....

User avatar
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
Posts: 23792
Joined: 22/09/2008 6:18 pm
Contact:

Re: มีปัญหาเรื่องการลง appserv คับ

Post by mindphp » 26/05/2010 4:39 pm

ดูเช็คดูว่า service ของ Apache ชี้ไปที่ path ไปที่ไหน
หรือลองหาโปรแกรมเช็ค port มาลงดูก็ได้ครับ ว่า port 80 ถูกใช้ โดย apache ตัวที่เราลงไว้หรือเปล่า

ปล. XAMPP มีพวกเช็คพวกนี้ให้อยู่แล้วครับ ใช้ XAMPP แทน appserv ไปเลยก็ได้ครับ ไม่ต้องมานั่งแก้ปัญหาทีละส่วน
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: https://www.mindphp.com/forums/viewforum.php?f=29
รับอบรม และพัฒนาระบบ: https://www.mindphp.com/forums/viewtopic.php?f=6&t=2042

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Programming - PHP”

Who is online

Users browsing this forum: No registered users and 91 guests