Page 1 of 1

จะทำอย่างไรไม่ให้ Xampp รัน PHP สองเวอร์ชั่น เวอร์ชั่น 7 start ขึ้นมาตอนกด start Xampp เวอร์ชั่น 5 ครับ

Posted: 11/11/2019 5:16 pm
by jamepiyawat
ผมใช้โปรแกรมจำลองเซฟเวอร์ Xampp ที่เป็น php 7 อยู่แต่ว่าผมนั้นได้ต้องการที่จะใช้ php 5 จึงได้ทำการติดตั้ง Xampp เวอร์ชั่น 5.6 ที่เป็น php เวอร์ชั่น 5

แต่ว่าพอติดตั้งเสร็จ ผมได้ทำการ start Xampp เวอร์ชั่น 5.6 แต่กลับ Xampp ที่เป็น php 7 ก็ start มาด้วยทำให้ localhost เป็นของ Xampp ที่เป็น php 7 จะทำอย่างไรไม่ให้ Xampp ที่เป็น php 7 start ขึ้นมาตอนที่ start Xampp เวอร์ชั่น 5.6 อยู่ครับ

ผมลองเปลี่ยนพอดแล้วก็ไมเป็นผล ครับ
Selection_999(1539).png
Selection_999(1539).png (37.93 KiB) Viewed 473 times
Selection_999(1537).png
Selection_999(1537).png (59.69 KiB) Viewed 473 times
Selection_999(1538).png
Selection_999(1538).png (31.15 KiB) Viewed 473 times

Re: จะทำอย่างไรไม่ให้ Xampp เวอร์ชั่น 7 start ขึ้นมาตอนกด start Xampp เวอร์ชั่น 5 ครับ

Posted: 11/11/2019 5:50 pm
by mindphp
ลองดู ไฟล์
/opt/lampp/etc/extra/httpd-xampp.conf

ตั้งค่า config ให้ ใช้ไฟล์ .so แต่ละเวอร์ชั่น ตามนี้

Code: Select all

   
   LoadModule php7_module        modules/libphp7.so
   LoadModule php5_module        modules/libphp5.so
เวลาจะ start ตัวไหน ให้ comment เวอร์ชั่นตรงข้ามไว้

Re: จะทำอย่างไรไม่ให้ Xampp เวอร์ชั่น 7 start ขึ้นมาตอนกด start Xampp เวอร์ชั่น 5 ครับ

Posted: 11/11/2019 6:29 pm
by jamepiyawat
ทำได้แล้วครับ ขอบคุณ ครับ